Copy pasting and clipboard not working in Remote Desktop (RDP)

Are you facing difficulties in making copy paste work from a local computer to a remote computer when using Remote Desktop Client (RDP)? Read this article to find the solution to the copy paste and clipboard issues in remote desktop connections.

I am using a Windows 7 laptop and frequently log in to my remote server running Windows 2008. I connect to local drives from the remote server to copy big files from local computer to the remote server. Sometimes I need to copy paste text using clipboard to remote computer. Copy pasting works pretty well from my desktop or laptop to the server without any problems, if you are using recent versions of remote desktop.

However, once in a while I get a problem with the clipboard sharing with the remote computer. If I copy some text from the local computer in the clipboard and try to paste it in the remote computer using Remote Desktop, it will not paste anything. It shows that there is no text in the clipboard.

Are facing the same problem with clipboard sharing and copy paste not working for you while using remote desktop? Here is the solution to this problem:

How to solve copy paste not working issue in Remote Desktop?

The clipboard sharing is handled using a small application running on the remote machine, called "RDPCLIP.EXE". If this application fails to do the job, your clipboard sharing will stop working and you will not be able to copy paste text, data or files from local computer to remote server using remote desktop connection.

Here is how you can solve this problem:

1. Login to remote computer using Remote Desktop (RDP)

2. Open Task Manager in the remote machine

3. Click the "Process" tab

4. Locate a program called "rdpclip.exe"

5. Right click and select "End process" to kill this program

6. Click on "File" menu in the task manager and select "New Task (Run)"

7. Type rdpclip.exe and press the button to start the process.

Kill rdpclip.exe to resolve copy paste not working error in Remote Desktop

By killing existing instance of the rdpclip.exe and restarting the program, you can get your copy paste work again in your remote desktop.

If the above steps do not resolve the copy paste and clipboard not working in remote desktop problem, please post your comments below. We can explore other options to resolve this. In my case, the above simple steps solved the problem and I am able to use copy paste as usual.

Article by Tony John
Tony John is a professional blogger from India, who started his first Weblog in 1998 at Tony switched to blogging as a passion blended business in the year 2000 and currently operates several popular web properties including,, and many more.

Follow Tony John or read 696 articles authored by Tony John

Related Articles

Teamviewer 10: Experience The Magic Of Remote Sharing

This is an article on the latest version of one of the best free collaboration software, Teamviewer which enables remote control on any PC, Mac, Laptop and Mobile devices where you can access either to any single application or the entire system.

More articles: Remote Sharing


Guest Author: Vamshi27 Mar 2012

I am facing the same problem recently when I try to connect to my other desktop at home through the team viewer application. The problem is that the copy/paste doesn't work on the remote system too when connected through the application and works when disconnected. I have tried almost most of the tips but nothing seems to be working for me. Please let me know if you have a solution to this. The remote desktop has Windows 7 on it.


Guest Author: Deep16 Jun 2012


As per suggestion we have tried to kill rdpclip.exe and launched it back but still we are facing the issue. We have tried on may computers but did not work. Please any other option .


Guest Author: Alex206118 Jul 2012

You can run the following commands on your remote machine one by one.

Taskkill.exe /im rdpclip.exe

This is a temporary fix, alternately you can use an online copy paste toil, its great.

Guest Author: Alex206118 Jul 2012

You can run the following commands on your remote machine one by one.

Taskkill.exe /im rdpclip.exe

This is a temporary fix, alternately you can use an online copy paste tool, its great.


Guest Author: Alex206125 Jul 2012

Please run these commands in sequence

1. type cmd in run window
2. Taskkill.exe /im rdpclip.exe
3. Rdpclip.exe

This will solve your copy/paste clipboard problem, you can also use an online copy paste tool, easy to use and fast.

Guest Author: Pat08 Nov 2012

I tried killing RDPCLIP and restarting it but still it does not work. My local workstation has Win7 Pro 64 bit and I am RDPing to 'Win Server 2008 R2 Standard with SP1'. It used to work earlier but somehow it stopped after reboot of last windows update on Nov 7, 2012.

Thanks in advance for any help,

Guest Author: Vaseem20 Nov 2012

Thanks a lot, this solved my issue; great help.

Guest Author: Rajat Kumar29 Nov 2012

Thanks a lot. It resolved my problem.

Guest Author: Vamshi04 Dec 2012

Thank you very much. It resolved my problem.

Guest Author: Vijay05 Dec 2012

Hi tried above mention advise still i am facing the same issue ,please help me 2 resolve it ASAP

Guest Author: Marco06 Dec 2012

Excellent, thanks for that! Worked perfectly for me.

Guest Author: Peter12 Feb 2013

I know this trick works. However this happens to me and my work colleagues on a regular basis on various servers.
Does anyone know what the possible causes for the rdpclip process to stop working properly could be?

Guest Author: Kamakshi Suram20 Feb 2013

Thank You very much . It worked for me

Guest Author: Egil04 Apr 2013

Just restarting the rdpclip.exe process helped.

Guest Author: Kasun21 May 2013

Thank you very much It really help me

Guest Author: Clipper25 Jun 2013

If killing/restarting rdpclip.exe does not work for you...

1. Start Remote Desktop Session Host Configuration (tsconfig.msc), go to the properties of the RDP-Tcp session and on the Client Settings tab make sure that Clipboard Redirection is unchecked.

You will need to disconnect and reconnect for the change to take effect. You may still need to kill/restart rdpclip.exe.

If that still doesn't work for you...

2. Go to the Group Policy Management Console.

In \Computer Configuration\Policies\Administrative Templates\Windows Components\Terminal Services\Terminal Server\Device and Resource Redirection and make sure that the "Do not allow Clipboard redirection" setting is Disabled.

REF: "Device and Resource Redirection" on MSDN.

Guest Author: Deepali29 Jun 2013

Thank you so much. This has been annoying me for quite a while. removing rdpclip process totally works.

Guest Author: Varun Maggo09 Jul 2013

As per suggestion we have tried to kill rdpclip.exe and launched it back.
Thanks it worked!

Author: Scott Dickey22 Jul 2013 Member Level: Bronze   Points : 2


I am using remote desktop RDC 2.1.1 for Mac and I am connecting to a Windows 7 machine. THe connection works fine but I cannot make copy/paste work. Before when I was connecting to the host machine with another Windows 7 machine copy/paste worked fine. I tried stopping and starting rdcclip.exe but no luck. Any ideas would be really helpful.

Guest Author: Greg20 Sep 2013

The tsconfig.msc comment worked for me. Nothing else was working. The clipboard was not disabled (check box was not there) but checked the box to disable it. Hit apply, then unchecked it and hit apply again. Working fine now.


Guest Author: Zorglub30 Oct 2013

Great, that worked!

Guest Author: Haynes11 Nov 2013

Hi All,

I hope this helps some of you.

After a lot of research, I noticed that my paste issue only occurred when I had my browser running. It transpired, that is was when any browser (Firefox, Safari, IE, etc) was running.

Long story short, it was my Webroot security software blocking some of my programs which were attempting to read the Clipboard.

It makes sense, I have a browser open so I wouldn't want an untrusted application gaining access to my clipboard as it may contain a password. I just hadn't realized that it was doing this. When I disabled the Protect Clipboard Data option, everything worked again.

Webroot prompted me to disallow / allow a particular program to access the clipboard, with an option to remember my choice. So, I gave certain programs permission and then switched the protection option back on, as I think that it is a great feature.

I would guess that other security suites use this methodology so if you are experiencing paste issues, you may find it beneficial to check your security suites settings.

Guest Author: gobinath22 Nov 2013

Thanks a lot. This solved my issue on using the Remote desktop of win7 from winblue system.

Guest Author: Sarika20 Feb 2014

Thank u so very much!!!! It resolved the issue.

Guest Author: jai01 Apr 2014

It worked for me. Thanks a lot.

Guest Author: krish11 Jul 2014

Worked for me. Thanks much for posting this.

Guest Author: Jaikumar Subramani28 Aug 2014

Above mentioned solution is not working. Can any one can share solution for the issue "copy paste not working from remote desktop to local in windows server 2003"

Guest Author: Mohammed ababiya25 Nov 2014

thank u for your post. I have done it correctly.

Guest Author: Nandakishord30 Dec 2014

This solution is not useful on Windows 8.1, as I am not able to copy paste while connect RDP to Windows 8.1 machine.

Please help me if any one know about this.

Guest Author: Ragnar05 Feb 2015

In some cases nothing will work except rebooting the server at fault. Some times it isn't an option so you'll have restort to save the information to files to transport back and forth.

This is one of the world oldest bugs still at large. Almost 2 decades old.
Few years ago I found information that Microsoft has no intentions to fix this bug.

It has to do with some kind of resource limitation or leaks. There are several data structures that haven't changed since the beginning of RDP, when memory was expensive en every free KB mattered. Some of the cause problems in high resolutions and when you have loaded Remote Desktop Servers.

No bug has cost my more wasted hours the last 15 years, it's in the hundreds.

Guest Author: swamy31 Mar 2015

Its perfectly working and simply superb the explanation.

Guest Author: naveen14 Apr 2015

Solved the issue. It worked. Thanks a lot

Guest Author: Duc Nguyen Hoang09 May 2015

Your way doesn't work for my scenario. My scenario:

Remote to a VM: shared cliboard works.
Remote to a physical PC: shared clipboard doesn't work.

Guest Author: Div02 Sep 2015

It is working. It worked when I checked the Administrator privileges box. Thanks for this informative article.

Guest Author: AMS15 Oct 2015

Solved the issue. It worked. Thanks a lot.

Guest Author: shsay04 Nov 2015

Thank you. The instructions worked for me!

Guest Author: Sunanda Dey16 Dec 2015

It Worked. Thanks for you instructions.

Guest Author: Guna07 Jan 2016

It is working for me by killing rdpclip.exe process in remote desktop.

Author: asus service17 Oct 2016 Member Level: Bronze   Points : 0


Thanks for sharing this article with us. Nice Post.

ASUS Service

Guest Author: Matt Froman28 Nov 2017

I have a work around. For RDS 2008 I had no problem copying and pasting, I set the session host/gateway to accept clipboard. However, with RDS 2016, I had to enable drive mapping for clipboard to work. RDS 2016 is very buggy and I hope they release fixes in R2. Of course, with drive mapping all the client drives came over, which I was not pleased about, but that is something they will have to fix. I performed a typical installation on RDS 2016 and the process is fully automated and really nothing you can mess up. RDS 2008 had a lot more configuration steps that could be performed. There was also a GUI to modify the .rdp file directly, which I have not found a way to do this is RDS 2016.

  • Do not include your name, "with regards" etc in the comment. Write detailed comment, relevant to the topic.
  • No HTML formatting and links to other web sites are allowed.
  • This is a strictly moderated site. Absolutely no spam allowed.
  • Name: